国产xxxx99真实实拍_久久不雅视频_高清韩国a级特黄毛片_嗯老师别我我受不了了小说

資訊專欄INFORMATION COLUMN

[HackerRank] Plus Minus

leeon / 3004人閱讀

Problem

Given an array of integers, calculate which fraction of its elements are positive, which fraction of its elements are negative, and which fraction of its elements are zeroes, respectively. Print the decimal value of each fraction on a new line.

Note

This challenge introduces precision problems. The test cases are scaled to six decimal places, though answers with absolute error of up to are acceptable.

Input Format

The first line contains an integer, , denoting the size of the array.
The second line contains space-separated integers describing an array of numbers .

Output Format

You must print the following lines:

A decimal representing of the fraction of positive numbers in the array.
A decimal representing of the fraction of negative numbers in the array.
A decimal representing of the fraction of zeroes in the array.
Sample Input

6
-4 3 -9 0 4 1  

   

Sample Output

0.500000
0.333333
0.166667

Solution

import java.io.*;
import java.util.*;
public class Solution {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int n = in.nextInt();
        int pos = 0, neg = 0, zero = 0;
        int[] A = new int[n];
        for (int i = 0; i < n; i++) {
            A[i] = in.nextInt();
        }
        for (int i = 0; i < n; i++) {
            if (A[i] == 0) zero++;
            else if (A[i] > 0) pos++;
            else neg++;
        }
        System.out.println((float) pos / n);
        System.out.println((float) neg / n);
        System.out.println((float) zero / n);
    }
}

文章版權歸作者所有,未經允許請勿轉載,若此文章存在違規行為,您可以聯系管理員刪除。

轉載請注明本文地址:http://specialneedsforspecialkids.com/yun/66016.html

相關文章

  • MV* 框架 與 DOM操作為主 JS庫 的案例對比

    摘要:中定義的處理業務邏輯與提供數據源,中的綁定負責渲染與響應用戶點擊拖拽等行為,這樣就最大保證了視圖邏輯相分離。遠離的世界,圍繞層控制器路由從后端放到前端,更加適合開發。 最近分別使用 Zepto 和 Avalon框架寫了個 SPA項目,貼出來討論下 JS DOM操作為主 JS庫 與 MV* 框架的對比 案例(MV* 框架 與 DOM操作 JS庫 實例對比) 購物車頁面 JS業務邏輯...

    springDevBird 評論0 收藏0
  • 發布一個基于 mprpc_config 二次封裝的 pip 包

    摘要:是一個超快速的庫,最近一直在看的東西,考慮如何應用到公司的項目中,模仿的方式二次封裝了一下。示例示例代碼在目錄啟動和原文發布一個基于二次封裝的包博客時空路由器 mprpc 是一個超快速的Python RPC 庫,最近一直在看 RPC 的東西,考慮如何應用到公司的項目中,模仿 Celery 的方式二次封裝了一下。 項目地址: mprpc_config 安裝 pip install mpr...

    sunsmell 評論0 收藏0
  • CSS外掛:Sass 之運算(加、減、乘、除)

    摘要:例如被編譯為最后一個栗子字符運算運算符可以用來連接字符串被編譯為注意,如果有引號的字符串被添加了一個沒有引號的字符串也就是,帶引號的字符串在符號左側,結果會是一個有引號的字符串。 學習Sass無非就是想高效的、 面向對象編寫CSS,Sass中的Operations也是重要的一部分。現在的前端各種工程化、模塊化、面向工資編程,哦...不對,是面向對象編程。玩起來吧! 1. 加減法 加減法...

    khs1994 評論0 收藏0
  • Python的@裝飾器是干什么用的?

    摘要:那么,這個裝飾器要怎么定義呢我們來看一下。當然了,如果大家在網絡上搜索,關于如何定義裝飾器,看到的是一個更加規范的版本。在當中,調用原函數時又,即把輸入的元祖解包再傳入。 ...

    NusterCache 評論0 收藏0
  • 一道原型上封裝的面試題

    摘要:既實現結果為的代碼知識點為原型增加方法。主要是考察對包裝類是否能用原型屬性,包裝類上也會有原型方法,只不過是包裝類的原型方法用的少而已。類上用的要多別外,類型的值,如果調用原型方法,需要把數學用括號括起來,要不然就是非法的浮點數了。 寫一段JS代碼,按下面的方式實現plus和minus方法: var a = (7).minus(2).plus(1); console.log(a)//...

    cgh1999520 評論0 收藏0

發表評論

0條評論

最新活動
閱讀需要支付1元查看
<